[SciPy-dev] site.cfg and acml

Arnd Baecker arnd.baecker at web.de
Mon Nov 14 09:51:06 CST 2005


On Mon, 14 Nov 2005, Nils Wagner wrote:

[...]

> >>> import scipy
> Importing test to scipy
> Importing base to scipy
> Importing basic to scipy
> Failed to import basic
> libacml.so: cannot open shared object file: No such file or directory
> Importing io to scipy
> Importing special to scipy
> Importing fftpack to scipy
> Failed to import fftpack
> libacml.so: cannot open shared object file: No such file or directory
> Importing utils to scipy
> Importing cluster to scipy
> Failed to import cluster
> libacml.so: cannot open shared object file: No such file or directory
> Importing sparse to scipy
> Importing interpolate to scipy
> Importing lib to scipy
> Importing signal to scipy
> Failed to import signal
> cannot import name random
> Importing integrate to scipy
> Importing optimize to scipy
> Failed to import optimize
> cannot import name random
> Importing linalg to scipy
> Importing stats to scipy
> Failed to import stats
> cannot import name random
> Importing basic to scipy
> Failed to import basic
> libacml.so: cannot open shared object file: No such file or directory
>
> This is my site.cfg
>
> #
> # AMD fast math libraries
> #
> [DEFAULT]
> #library_dirs = /usr/local/lib:/opt/acml2.7.0/gnu32/lib:/usr/lib
> library_dirs = /opt/acml2.7.0/gnu32/lib
>
> [blas]
> #
> # for overriding the names of the atlas libraries
> #
> blas_libs = acml
> language = f77
>
> [lapack]
> lapack_libs = acml
> language = f77
>
> How can I resolve the problem ?

Have you tried to set
  LD_LIBRARY_PATH
(maybe also LD_RUN_PATH) to /opt/acml2.7.0/gnu32/lib ?

Arnd




More information about the Scipy-dev mailing list