[SciPy-dev] scipy 0.4.3 won't build with gcc 4.0.1 (Xcode 2.2) on Macos X

Robert Kern robert.kern at gmail.com
Fri Nov 18 01:36:30 CST 2005


Jeff Whitaker wrote:
> gcc 4.0.1 doesn't like nested functions on MacOS X.

There are enough things that gcc 4 doesn't like that I always recommend
OS X 10.4 users to use gcc 3.3 when building scipy. Or anything else,
really. Use this command to switch:

$ sudo gcc_select 3.3

-- 
Robert Kern
robert.kern at gmail.com

"In the fields of hell where the grass grows high
 Are the graves of dreams allowed to die."
  -- Richard Harter




More information about the Scipy-dev mailing list