[SciPy-dev] newcore and gcc4/gfortran (only 3 tests fail now)

Arnd Baecker arnd.baecker at web.de
Mon Nov 21 05:16:29 CST 2005


On Mon, 21 Nov 2005, Pearu Peterson wrote:

[...]

> I suspect that your blas/lapack libraries are built with g77 3.x.

Yep!

> Try adding -lg2c to linkage command

Just to be sure: when building blas/lapack
or when building scipy?
For the latter: What is the best way to do this?
Can one add a flag to the build command
  python setup.py config_fc --fcompiler=gnu95 build
?

> or upgrade gfortran.

I will leave this aside for the moment as I am not root
on that machine which means to build gcc/gfortran
in a separate place (not a big deal, but I have to finish some
other stuff before ...)

Best,

Arnd




More information about the Scipy-dev mailing list