[SciPy-dev] 12 errors using 0.7.3.1538 0.4.2_1461

Travis Oliphant oliphant.travis at ieee.org
Wed Nov 30 16:24:28 CST 2005


Stephen Walton wrote:

>Stephen Walton wrote:
>
>  
>
>>I'm afraid that I'm getting a very similar set of errors to Nils.  I 
>>have BLAS, LAPACK, and ATLAS 3.7.11 locally compiled using Absoft 
>>Fortran 95, and Scipy also compiled with the same compiler, on Fedora 
>>Core 4.  On another FC4 system, which is using gfortran 4.0.2 as the 
>>compiler and ATLAS 3.6.0 distributed by Fedora Extras, I'm getting the 
>>same 12 errors as Nils.  Output from the Absoft based system below.  
>>Both are scipy core version 0.7.4.1545 and scipy version 0.4.2_1443
>> 
>>
>>    
>>
>Correction:  scipy version is 1467, not 1443.  It turns out there's a 
>minor bug in how scipy gets built:  if the build gets interrupted for 
>some reason an old version of Lib/__svn_version__.py gets left lying 
>around, and is not deleted the next time a build is started.
>
>  
>
Perhaps this bug is causing your Lib/sparse/sparse.py to not get updated 
as well. 

Some of the errors being reported are due to changes in scipy core.   
The sparse.py file received an appropriate fix.  Somehow this is not 
getting propagated to your installed version of scipy (even though it's 
been checked in to svn).

Please check

<your Python installation site>/scipy/sparse/sparse.py

and compare with

<your svn checkout site>/Lib/sparse/sparse.py

In particular, make sure the spmatrix class defines the 
__array_priority__  attribute.

-Travis




More information about the Scipy-dev mailing list