[SciPy-dev] 12 errors using 0.7.3.1538 0.4.2_1461

Stephen Walton stephen.walton at csun.edu
Wed Nov 30 18:25:31 CST 2005


Travis Oliphant wrote:

>Some of the errors being reported are due to changes in scipy core.   
>The sparse.py file received an appropriate fix.  Somehow this is not 
>getting propagated to your installed version of scipy (even though it's 
>been checked in to svn).
>
>Please check
>
><your Python installation site>/scipy/sparse/sparse.py
>
>and compare with
>
><your svn checkout site>/Lib/sparse/sparse.py
>  
>
These two files were identical, and neither included the 
__array_priority__ attribute, even though "svn up" reported earlier 
today that I was at revision 1467,.  So on one machine I manually 
deleted Lib/sparse/sparse.py and did "svn up."  On another machine I 
just did "svn up."  Both now are at revision 1471 of scipy and sparse.py 
contains the __array_priority__ attribute.  With this resolved, all of 
the sparse matrix test failures are gone.  There are a few others which 
I will investigate a bit after the next update.

Steve




More information about the Scipy-dev mailing list