[SciPy-dev] Cannot build scipy_core (newcore) on Solaris 8

Travis Oliphant oliphant at ee.byu.edu
Fri Oct 7 18:00:55 CDT 2005


Christopher Hanley wrote:

> The config.h file is attached.
>
Sorry I didn't get back to you, earlier.

Add the following line to your config.h file

#define HAVE_INVERSE_HYPERBOLIC_FLOAT


If that doesn't work, then  you may want to add

#define HAVE_LONGDOUBLE_FUNCS
#define HAVE_FLOAT_FUNCS

as well (one at a time).

Place this config.h file in the build directory where you got it from 
(you might also copy it to the installation directory --- or check to 
make sure one isn't there already).   These headers are installed to 
site-packages/scipy/base/include

so look there to make sure you don't have something already (if you do 
delete it).

Also, remove any scipy subdirectory under the place where your python 
includes are

Mine are in /usr/include/python2.4  so I would execute  rm 
/usr/include/python2.4/scipy

We don't want to be pulling out the wrong config file.


If we can get a good config.h file for your platform, then we see about 
how to make it generated automatically.

-Travis






More information about the Scipy-dev mailing list