[SciPy-dev] bdist_rpm problems

Stephen Walton stephen.walton at csun.edu
Fri Oct 7 18:53:18 CDT 2005


I'm seeing a couple of problems with "setup.py bdist_rpm".  If this is 
still in progress, so be it, but here are the specific issues I'm hitting:

1. "setup.py config_fc --fcompiler=absoft bdist_rpm" in newcore still 
uses g77, even though "setup.py config_fc --fcompiler=absoft build" uses 
Absoft.

2.  With today's SVN checkout, newscipy's bdist_rpm command isn't 
working at all, with the output:

Assuming default configuration (Lib/utils/{setup_utils,setup}.py was not 
found)
Appending scipy.utils configuration to scipy
Appending scipy.io configuration to scipy
Appending scipy.special configuration to scipy
lapack_opt_info:
atlas_threads_info:
Setting PTATLAS=ATLAS
scipy.distutils.system_info.atlas_threads_info
  NOT AVAILABLE

atlas_info:
scipy.distutils.system_info.atlas_info
  FOUND:
    libraries = ['lapack', 'f77blas', 'cblas', 'atlas']
    library_dirs = ['/usr/lib/atlas']
    language = f77
    include_dirs = ['/usr/include/atlas']

running build_src
building extension "atlas_version" sources
  adding 'build/src/atlas_version_-0x51ab4a5a.c' to sources.
running build_ext
customize UnixCCompiler
customize UnixCCompiler using build_ext
customize GnuFCompiler
customize GnuFCompiler
customize GnuFCompiler using build_ext
  FOUND:
    libraries = ['lapack', 'f77blas', 'cblas', 'atlas']
    library_dirs = ['/usr/lib/atlas']
    language = f77
    define_macros = [('ATLAS_INFO', '"\\"3.7.11\\""')]
    include_dirs = ['/usr/include/atlas']

Appending scipy.optimize configuration to scipy
Appending scipy.stats configuration to scipy
Appending scipy.interpolate configuration to scipy
Appending scipy configuration to
Creating Lib/__svn_version__.py (version='1318')
running bdist_rpm
creating build/bdist.linux-i686
creating build/bdist.linux-i686/rpm
creating build/bdist.linux-i686/rpm/SOURCES
creating build/bdist.linux-i686/rpm/SPECS
creating build/bdist.linux-i686/rpm/BUILD
creating build/bdist.linux-i686/rpm/RPMS
creating build/bdist.linux-i686/rpm/SRPMS
writing 'build/bdist.linux-i686/rpm/SPECS/scipy.spec'
running sdist
warning: sdist: standard file not found: should have one of README, 
README.txt
Traceback (most recent call last):
  File "setup.py", line 35, in ?
    setup_package()
  File "setup.py", line 26, in setup_package
    url = "http://www.scipy.org",
  File "/usr/lib/python2.4/site-packages/scipy/distutils/core.py", line 
80, in setup
    return old_setup(**new_attr)
  File "/usr/lib/python2.4/distutils/core.py", line 149, in setup
    dist.run_commands()
  File "/usr/lib/python2.4/distutils/dist.py", line 946, in run_commands
    self.run_command(cmd)
  File "/usr/lib/python2.4/distutils/dist.py", line 966, in run_command
    cmd_obj.run()
  File "/usr/lib/python2.4/distutils/command/bdist_rpm.py", line 305, in run
    self.run_command('sdist')
  File "/usr/lib/python2.4/distutils/cmd.py", line 333, in run_command
    self.distribution.run_command(command)
  File "/usr/lib/python2.4/distutils/dist.py", line 966, in run_command
    cmd_obj.run()
  File "/usr/lib/python2.4/distutils/command/sdist.py", line 143, in run
    self.get_file_list()
  File "/usr/lib/python2.4/distutils/command/sdist.py", line 240, in 
get_file_list
    self.add_defaults()
  File 
"/usr/lib/python2.4/site-packages/scipy/distutils/command/sdist.py", 
line 9, in add_defaults
    old_sdist.add_defaults(self)
  File "/usr/lib/python2.4/distutils/command/sdist.py", line 305, in 
add_defaults
    self.filelist.extend(build_clib.get_source_files())
  File 
"/usr/lib/python2.4/site-packages/scipy/distutils/command/build_clib.py", 
line 95, in get_source_files
    filenames.extend(get_lib_source_files(lib))
  File "/usr/lib/python2.4/site-packages/scipy/distutils/misc_util.py", 
line 227, in get_lib_source_files
    depends = build_info.get('depends',[])

3. I *think*, although I cannot be sure, that both scipy_core and scipy 
are installing __svn_version__.py files in 
/usr/lib/python-x.y/site-packages/scipy.  I don't think this is 
intended, and means that, once bdist_rpm is working, one won't be able 
to install both without using --replacefiles.




More information about the Scipy-dev mailing list