[SciPy-dev] Is scipy_core requiring a FORTRAN compiler?

Travis Oliphant oliphant at ee.byu.edu
Tue Oct 11 16:55:44 CDT 2005


Christopher Hanley wrote:

> Hi Travis,
>
> I was under the impression that there was no FORTRAN code in 
> scipy_core.  However, I recently tried re-building on a system that 
> had an improperly defined F77 environment variable and the build 
> failed.  Is this only occurring because I have ATLAS and BLAS on my 
> system or is there now FORTRAN code in SCIPY_CORE?

No, no fortran code,  If anything it is scipy.distutils choking.  SciPy 
distutils supports Fortran compilers but should not need them for scipy 
core.  So, I'm not sure what the problem is.  Show us the build log.

What is the error?

By the way, where do we stand on the Solairs build.  I was distracted 
trying to resolve some issues on a 64-bit system.

-Travis




More information about the Scipy-dev mailing list