[SciPy-dev] newscipy/Lib/sparse

Robert Cimrman cimrman3 at ntc.zcu.cz
Wed Oct 19 08:26:14 CDT 2005


Ed Schofield wrote:
> Robert Cimrman wrote:
> 
> 
>>Then when I comment out the 'from scipy.base.fastumath import *' line in 
>>Sparse.py, I get
>>
>>...
>>/usr/lib/python2.4/site-packages/scipy/sparse/Sparse.py
>>/usr/lib/python2.4/site-packages/scipy/sparse/_superlu.py
>>ImportError: 
>>/home/share/software/usr/lib/python2.4/site-packages/scipy/sparse/_zsuperlu.so: 
>>undefined symbol: strsm_
>> 
>>
> 
> 
> I suggest we should strip away the SuperLU bindings until we've got the
> basic sparse data types working to our satisfaction.

Good suggestion :-). Now after commenting out also 'import _superlu' the 
import scipy.sparse succeeds. I am now converting Sparse.py for the 
newcore-type arrays.

>>As a side-note, my installation of scipy really is in 
>>'/home/share/software/usr/lib/python2.4/site-packages'. ipython (and the 
>>regular python shell as well) nevertheless prints 
>>'/usr/lib/python2.4/site-packages' in the tracebacks. Does anybody know 
>>how to fix it?
>> 
> Try changing your PYTHONPATH environment variable so it only points to
> site-packages/ where the new scipy is installed.

That is what I have :(

r.




More information about the Scipy-dev mailing list