[SciPy-dev] Numeric 24, matplotlib, etc. (was: Re: TypeError: __array_data__ must return a string providing the pointer to data)

Stephen Walton stephen.walton at csun.edu
Sat Oct 22 17:56:20 CDT 2005


Travis Oliphant wrote:

>Installing Numeric 24.0 and scipy core allows matplotlib to work with 
>scipy core arrays (they get quickly converted to Numeric 24.0 arrays 
>behind the scenes using the array interface).
>
Is 24.0 still around for download somewhere?  I used an old archive of 
24.0b2 I had lying around, but didn't see Numeric 24 on Sourceforge, 
either as a download or from CVS.

It gets worse, because it turns out that the Ubuntu numeric packagers 
have broken it up into python-numeric, python2.4-numeric, and 
python2.4-numeric-ext.  John Hunter, are you out there?  I know you use 
Ubuntu;  are you just using old scipy until you get a chance to port 
matplotlib to new core?

Followups redirected to scipy-user, since IMHO this is no longer a 
scipy-dev discussion.




More information about the Scipy-dev mailing list