[SciPy-dev] All but two tests passing for me

Travis Oliphant oliphant at ee.byu.edu
Thu Oct 27 19:38:06 CDT 2005


Fernando Perez wrote:

>Did you have a look at the logs posted yesterday by Andrew about the Itanium 
>builds?  It seems like getting the build process on that box to work still is 
>very manual-labor intensive.  If you have any pointers, they'd be greatly 
>appreciated.
>
>  
>
Yes, I looked at the logs he reported.    His problems look like an 
issue with the Python installation.  There are a lot of underfined 
references to basic Python C-API calls.   Somehow he is not linking 
against the Python library?  I don't know why that is the case.

Perhaps scipy.distutils is not picking up where his Python library is 
located (it looks like he has Python installed in some non-standard 
place).    Or when he links with f77 the Python library is not included.

I'm not really sure what's going on. 

So, I think the problems Andrew is having have to do with non-standard 
installation issues and not 64-bit issues.

>Andrew - I can try to work on this with you a little tomorrow if you are 
>interested.  We can try to get the full newscipy to build on Itanium2 and 
>report back.  I'd really like to have full 64-bit support out of the box when 
>the new code is released.
>  
>
I don't think his issues are 64-bit related at all.    

Scipy core is pretty clean with 64-bit support.

Newscipy is mostly clean (signaltools had alot of places where int * was 
assumed for strides and dimensions that I think were changed --- but I'm 
not sure if everything was fixed).


-Travis





More information about the Scipy-dev mailing list