[SciPy-dev] New Lyx Version eas(ier) to install on Windows.

Travis Oliphant oliphant at ee.byu.edu
Sun Sep 4 04:00:29 CDT 2005


Alan G Isaac wrote:

>On Fri, 02 Sep 2005, Travis Oliphant apparently wrote: 
>  
>
>>those of you who have been hesitant to try LyX because it supposedly 
>>doesn't work on Windows, have no more excuse ;-) 
>>    
>>
>
>  
>
>>An executable installer is available at http://www.lyx.org 
>>    
>>
>
>  
>
>>The setup process guides you through the other programs that are needed 
>>(ImageMagick, Ghostscript, a minimal shell like minsys, Python, and 
>>optionally Perl)  to run lyx well. 
>>    
>>
>
>1. A question: what ImageMagick file is needed?
>   http://sourceforge.net/project/showfiles.php?group_id=24099
>   (I.e., what do you get out of "dynamic"?)
>   Comment: ImageMagick seems very RAM intensive.
>  
>
You just need the program convert (use the Q8 version which assumes 8 
bits per channel rather than the more RAM intensive 16 bit-per channel 
Q16 version).  Lots of ImageMagick versions will work.  If you don't 
have the convert.exe program, the program should still work, but you 
won't be able to see  graphics included in the file on screen.

>2. I do not see the shell requirment.  Is that just your 
>   recommendation?
>  
>
The new installer for Lyx 1.3.6 on windows will guide you through and 
ask for the directory where sh.exe  lives, or I think it tries to 
download msys for you.

>3. Are you using it on Windows?  If so, how's it going?
>  
>
I edited on Windows last night, and it seemed just fine.  My main 
platform is not Windows, however.


-Travis





More information about the Scipy-dev mailing list