[SciPy-dev] Scipy vs. Fedora Core 4

Ravikiran Rajagopal ravi at ati.com
Wed Sep 14 13:56:58 CDT 2005


Hi,

On Wednesday 14 September 2005 12:45, Fernando Perez wrote:
> Stephen Walton wrote:
> >>Despite the above, I think Ravi's patch should be incorporated into
> >>Scipy.
> > [ ... ] If gfortran won't compile
> > them correctly, then you won't get the right answer and gfortran should
> > not be used to build Scipy.

The application of the patches (with your suggested modifications along with a 
big notice saying that gfortran is not supported) will not change anything 
for the people who do not use gfortran. However, it would make life easier 
for those who do and might get us more testers who can make scipy usable with 
gfortran. At some point, gfortran will need to be supported, since g77 is 
unmaintained now.

As noted, the bug fixes for linalg will need to be made at some point too.

> In a very selfish way, thank you for going first and getting the arrows on
> your back ;)

Going first - but only because I need Python 2.4.

Regards,
Ravi




More information about the Scipy-dev mailing list