[SciPy-dev] setup/config problem with scipy svn

Andrew Straw strawman at astraw.com
Mon Apr 3 12:08:50 CDT 2006


I'm not sure it'll help (there may be a new problem, as you suggest),
but I've found that numpy distutils is brittle when it comes to figuring
out the right commands, thus I specify them explicitly:

python setup.py build_src build_clib build_ext --fcompiler=gnu

John Hunter wrote:

>I just tried updating and building scipy from svn (which I've built on
>this platform recently in the last week) and am now getting
>
>python/svn/scipy> uname -a
>Linux peds-pc311 2.6.10-5-386 #1 Thu Aug 18 22:23:56 UTC 2005 i686
>GNU/Linux
>python/svn/scipy> svn up
>At revision 1808.
>python/svn/scipy> rm -rf build
>python/svn/scipy> python setup.py build
>/usr/lib/python2.4/distutils/dist.py:236: UserWarning: Unknown
>distribution option: 'configuration'
>  warnings.warn(msg)
>running build
>running config_fc
>python/svn/scipy>
>
>and nothing happens -- no build, no compile, etc...
>
>JDH
>
>_______________________________________________
>Scipy-dev mailing list
>Scipy-dev at scipy.net
>http://www.scipy.net/mailman/listinfo/scipy-dev
>  
>




More information about the Scipy-dev mailing list