[SciPy-dev] scipy.sparse + umfpack + system_info

Robert Cimrman cimrman3 at ntc.zcu.cz
Mon Apr 10 06:38:52 CDT 2006


Nils Wagner wrote:
>  I have installed UMFPACK 4.6.
> 
>  >>> from scipy import *
> import linsolve.umfpack -> failed: 
> /usr/lib64/python2.4/site-packages/scipy/linsolve/umfpack/__umfpack.so: 
> undefined symbol: e_wsfe
> 
> Is the wrapper restricted to version 4.4 ?

Yes, it is tested to work with 4.4. But stay tuned. There are many 
interesting algorithms in 4.6, and I may be tempted... :)

r.




More information about the Scipy-dev mailing list