[SciPy-dev] scipy.sparse + umfpack + system_info

Nils Wagner nwagner at iam.uni-stuttgart.de
Mon Apr 10 07:09:11 CDT 2006


Robert Cimrman wrote:
> Nils Wagner wrote:
>   
>>  I have installed UMFPACK 4.6.
>>
>>  >>> from scipy import *
>> import linsolve.umfpack -> failed: 
>> /usr/lib64/python2.4/site-packages/scipy/linsolve/umfpack/__umfpack.so: 
>> undefined symbol: e_wsfe
>>
>> Is the wrapper restricted to version 4.4 ?
>>     
>
> Yes, it is tested to work with 4.4. But stay tuned. There are many 
> interesting algorithms in 4.6, and I may be tempted... :)
>
> r.
>
> _______________________________________________
> Scipy-dev mailing list
> Scipy-dev at scipy.net
> http://www.scipy.net/mailman/listinfo/scipy-dev
>   
Hi Robert,

The problem persists with version 4.4
Am I missing something ?

 >>> import scipy
import linsolve.umfpack -> failed: 
/usr/lib64/python2.4/site-packages/scipy/linsolve/umfpack/__umfpack.so: 
undefined symbol: e_wsfe

umfpack_info:
    libraries = ['umfpack', 'amd', 'f77blas', 'cblas', 'atlas']
    library_dirs = ['/usr/local/src/UMFPACKv4.4/UMFPACK/Lib', 
'/usr/local/src/UMFPACKv4.4/AMD/Lib', '/usr/local/lib/atlas']
    define_macros = [('SCIPY_UMFPACK_H', None), ('SCIPY_AMD_H', None), 
('ATLAS_INFO', '"\\"3.7.11\\""')]
    swig_opts = ['-I/usr/local/src/UMFPACKv4.4/UMFPACK/Include', 
'-I/usr/local/src/UMFPACKv4.4/AMD/Include']
    include_dirs = ['/usr/local/src/UMFPACKv4.4/UMFPACK/Include', 
'/usr/local/src/UMFPACKv4.4/AMD/Include']
amd_info:
    libraries = ['amd']
    library_dirs = ['/usr/local/src/UMFPACKv4.4/AMD/Lib']
    define_macros = [('SCIPY_AMD_H', None)]
    swig_opts = ['-I/usr/local/src/UMFPACKv4.4/AMD/Include']
    include_dirs = ['/usr/local/src/UMFPACKv4.4/AMD/Include']

Nils




More information about the Scipy-dev mailing list