[SciPy-dev] Trouble with UMFPACK 5.0

Robert Cimrman cimrman3 at ntc.zcu.cz
Thu Dec 7 05:48:57 CST 2006


Nils Wagner wrote:
> Robert Cimrman wrote:
>> Nils Wagner wrote:
>>   
>>> I have replaced the commas by colons in my site.cfg.
>>>
>>> [DEFAULT]
>>> library_dirs = /usr/lib:/usr/local/lib:/usr/lib64
>>> include_dirs = /usr/include:/usr/local/include
>>>
>>> [amd]
>>> library_dirs = /usr/local/src/AMD/Lib
>>> include_dirs = /usr/local/src/AMD/Include:/usr/local/src/UFconfig
>>> amd_libs = amd
>>>
>>> [umfpack]
>>> library_dirs = /usr/local/src/UMFPACK/Lib
>>> include_dirs = /usr/local/src/UMFPACK/Include:/usr/local/src/UFconfig
>>> umfpack_libs = umfpack
>>>
>>> Now I get
>>> ...
>>> creating build/temp.linux-x86_64-2.4/build/src.linux-x86_64-2.4/Lib/linsolve
>>> creating
>>> build/temp.linux-x86_64-2.4/build/src.linux-x86_64-2.4/Lib/linsolve/umfpack
>>> compile options: '-DSCIPY_UMFPACK_H -DSCIPY_AMD_H
>>> -DATLAS_INFO="\"3.7.11\"" -I/usr/local/src/UMFPACK/Include
>>> -I/usr/local/src/AMD/Include
>>> -I/usr/local/lib64/python2.4/site-packages/numpy/core/include
>>> -I/usr/include/python2.4 -c'
>>>     
>> -I/usr/local/src/UFconfig is missing here, strange. Could you try to 
>> copy or link manually UFconfig.h into e.g. /usr/local/src/UMFPACK/Include?
>>
>>   
> I have put a copy of UFconfig.h into
> 
> /usr/local/src/UMFPACK/Include.
> 
> locate UFconfig.h
> 
> /usr/local/src/UFconfig/UFconfig.h
> /usr/local/src/UMFPACK/Include/UFconfig.h
> 
> 
> With that I was able to install scipy. But scipy.test(1) yields
> 
>   Found 4 tests for scipy.io.recaster
> Warning: FAILURE importing tests for <module
> 'scipy.linsolve.umfpack.umfpack' from '...y/linsolve/umfpack/umfpack.pyc'>
> /usr/local/lib64/python2.4/site-packages/scipy/linsolve/umfpack/tests/test_umfpack.py:17:
> AttributeError: 'module' object has no attribute 'umfpack' (in ?)
> Warning: FAILURE importing tests for <module 'scipy.linsolve.umfpack'
> from '.../linsolve/umfpack/__init__.pyc'>
> /usr/local/lib64/python2.4/site-packages/scipy/linsolve/umfpack/tests/test_umfpack.py:17:
> AttributeError: 'module' object has no attribute 'umfpack' (in ?)
>   Found 4 tests for scipy.optimize.zeros
> 
> Any idea ?

I am puzzled. It might be a 64-bit issue? Could you send me the relevant 
part of compilation output?

r.


More information about the Scipy-dev mailing list