[SciPy-dev] Found! - Why scipy-0.4.4 won't build on FC5

Neal Becker ndbecker2 at gmail.com
Wed Feb 1 13:50:41 CST 2006


It looks like the problem is in numpy/distutils/fcompiler/gnu.py

It's the version_pattern!

Old f77:
f77 --version
GNU Fortran (GCC 3.2.3 20030502 (Red Hat Linux 3.2.3-54.fc5)) 3.2.3 20030502
(Red Hat Linux 3.2.3-13)

New gfortran:
gfortran --version
GNU Fortran 95 (GCC) 4.1.0 20060128 (Red Hat 4.1.0-0.17)

Notice this doesn't match version_pattern:
    version_pattern = r'GNU Fortran 95 \(GCC (?P<version>[^\s*\)]+)'

Also, doesn't gnu.py need this?
        'linker_so'    : [fc_exe,"-shared", "-Wall"],

(-shared was missing)





More information about the Scipy-dev mailing list