[SciPy-dev] Renaming scipy_core ???

Fernando Perez Fernando.Perez at colorado.edu
Mon Jan 2 10:17:26 CST 2006


Travis Oliphant wrote:

>>I've been happy with the name "numerix" in matplotlib.  It is intended
>>to connote "Numeric" in plural, eg numeric, numarray and (now) scipy
>>core.  Also, the import abbrev
>>
>> import numerix as nx
>>
>>is a good mnemonic and is less likely to clash with the local
>>namespace than other popular historical choices
>> 
>>
> 
> I like the numerix name.  My only concern is would that mess up the use 
> of numerix as a superset of all the array packages?  Perhaps that would 
> be a "good thing" :-)

I'm also +1 on numerix (I'd forgotten about it, but I've always liked it). 
There seems to be some consensus building on this one, at least from the votes 
today.

Even though I like a lot the idea of naming it just 'nx' as Robert suggested, 
I think that nx is too likely to collide with codes that have (nx,ny,nz) 
variables in them (quite common).  Leaving the actual package name as 
'numerix' allows everybody to choose a local shorthand that doesn't cause name 
collisions in their own namespace.

So my vote is

+1 numerix -> the new scipy_core name
+1 ndarray -> the new name for the actual array package

with the possibility that, in the future, ndarray may be pitched for inclusion 
in the core.

Cheers,

f

ps - Travis, thanks for humoring my concerns on this at such a late time. 
Your patience is much appreciated.




More information about the Scipy-dev mailing list