[SciPy-dev] Now new svn of numpy is ready

Fernando Perez Fernando.Perez at colorado.edu
Thu Jan 5 02:23:18 CST 2006


Arnd Baecker wrote:
> success!
> 
> Installing numpy/scipy on the opteron:
> 
> In [8]: numpy.__version__
> Out[8]: '0.9.2.1818'
> 
> numpy.test(10)
> Ran 178 tests in 0.171s
> 
> In [7]: scipy.__numpy_version__
> Out[7]: '0.9.2.1818'
> 
> scipy.test(10)
> Ran 945 tests in 56.373s

On my Fedora 3 x86 box, using python2.3, gcc 3.4.4:

abdul[scipy]> ./testpkg numpy
[...]
----------------------------------------------------------------------
Ran 178 tests in 4.986s

OK
********************************************************************************

Package: numpy
Version: 0.9.2.1818

abdul[scipy]> ./testpkg scipy
[...]
======================================================================
ERROR: line-search Newton conjugate gradient optimization routine
----------------------------------------------------------------------
Traceback (most recent call last):
   File 
"/home/fperez/usr/local/lib/python2.3/site-packages/scipy/optimize/tests/test_optimize.py", 
line 104, in check_ncg
     full_output=False, disp=False, retall=False)
   File 
"/home/fperez/usr/local/lib/python2.3/site-packages/scipy/optimize/optimize.py", 
line 969, in fmin_ncg
     alphak, fc, gc, old_fval = line_search_BFGS(f,xk,pk,gfk,old_fval)
   File 
"/home/fperez/usr/local/lib/python2.3/site-packages/scipy/optimize/optimize.py", 
line 556, in line_search_BFGS
     phi_a2 = apply(f,(xk+alpha2*pk,)+args)
   File 
"/home/fperez/usr/local/lib/python2.3/site-packages/scipy/optimize/optimize.py", 
line 133, in function_wrapper
     return function(x, *args)
   File 
"/home/fperez/usr/local/lib/python2.3/site-packages/scipy/optimize/tests/test_optimize.py", 
line 31, in func
     raise RuntimeError, "too many iterations in optimization routine"
RuntimeError: too many iterations in optimization routine

----------------------------------------------------------------------
Ran 945 tests in 114.135s

FAILED (errors=1)
********************************************************************************

Package: scipy
Version:
Traceback (most recent call last):
   File "/usr/local/lib/python2.3/site-packages/test.py", line 28, in ?

AttributeError: 'module' object has no attribute '__version__'


Could we please have scipy.__version__ as well, in addition to 
scipy.__numpy_version__?

Cheers,

f

ps - I'm attaching the make/test scripts that I'm using, in case anyone finds 
them useful to do this over and over.  They both work as

scriptname [scipy/numpy]

The make one does a make/install, just configure your preferred python version 
and install prefix.  For scipy, we'll need scipy.__version__ to be added so it 
works without that last error.
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: makepkg
Url: http://projects.scipy.org/pipermail/scipy-dev/attachments/20060105/5bdfc7c5/attachment.pl 
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: testpkg
Url: http://projects.scipy.org/pipermail/scipy-dev/attachments/20060105/5bdfc7c5/attachment-0001.pl 


More information about the Scipy-dev mailing list