[SciPy-dev] Import strategy

Pearu Peterson pearu at scipy.org
Mon Jan 9 03:48:23 CST 2006



On Mon, 9 Jan 2006, Nils Wagner wrote:

> Strange. Here I get
>
> from scipy import *
> ...
> Overwriting linalg=<module 'scipy.basic.linalg' from
> '/usr/local/lib/python2.4/site-packages/scipy/basic/linalg.pyc'> from
> /usr/local/lib/python2.4/site-packages/scipy/basic/linalg.pyc (was
> <module 'scipy.linalg' from
> '/usr/local/lib/python2.4/site-packages/scipy/linalg/__init__.pyc'> from
> /usr/local/lib/python2.4/site-packages/scipy/linalg/__init__.pyc)
> Overwriting fftpack=<module 'scipy.basic.fftpack' from
> '/usr/local/lib/python2.4/site-packages/scipy/basic/fftpack.pyc'> from
> /usr/local/lib/python2.4/site-packages/scipy/basic/fftpack.pyc (was
> <module 'scipy.fftpack' from
> '/usr/local/lib/python2.4/site-packages/scipy/fftpack/__init__.pyc'>
> from /usr/local/lib/python2.4/site-packages/scipy/fftpack/__init__.pyc)
>>>> linalg.logm
> Traceback (most recent call last):
>  File "<stdin>", line 1, in ?
> AttributeError: 'module' object has no attribute 'logm'
>>>> import numpy
>>>> numpy.__version__
> '0.9.3.1860'
>>>> import scipy
>>>> scipy.__version__
> '0.4.4.1540'
>
>
> BTW, I haven't uninstalled the "old" core but installed numpy.

That could be it, all kind of strange things can happen when not removing 
(hiding, whatever) old scipy before installing recent numpy/scipy 
packages. I suggest also using scipy from recent svn (1542 and up).

Pearu




More information about the Scipy-dev mailing list