[SciPy-dev] Detection of fft libraries on 64 bit machines

Nils Wagner nwagner at mecha.uni-stuttgart.de
Thu Jan 12 04:00:58 CST 2006


Hi all,

I have installed the fftw rpm's (fftw, fftw-devel, fftw3, fftw3-devel)
on a 64 bit machine (SuSE 9.3). The libraries are located
in /usr/lib64

/usr/lib64/libdfftw.a
/usr/lib64/libdfftw.la
/usr/lib64/libdfftw.so
/usr/lib64/libdfftw.so.2
/usr/lib64/libdfftw.so.2.0.5
/usr/lib64/libdrfftw.a
/usr/lib64/libdrfftw.la
/usr/lib64/libdrfftw.so
/usr/lib64/libdrfftw.so.2
/usr/lib64/libdrfftw.so.2.0.5

/usr/lib64/libfftw3.a
/usr/lib64/libfftw3.la
/usr/lib64/libfftw3.so
/usr/lib64/libfftw3.so.3
/usr/lib64/libfftw3.so.3.0.1
/usr/lib64/libfftw3f.a
/usr/lib64/libfftw3f.la
/usr/lib64/libfftw3f.so
/usr/lib64/libfftw3f.so.3
/usr/lib64/libfftw3f.so.3.0.1
/usr/lib64/libfftw3f_threads.so.3
/usr/lib64/libfftw3f_threads.so.3.0.1
/usr/lib64/libfftw3_threads.so.3
/usr/lib64/libfftw3_threads.so.3.0.1

/usr/lib64/libsfftw.a
/usr/lib64/libsfftw.la
/usr/lib64/libsfftw.so
/usr/lib64/libsfftw.so.2
/usr/lib64/libsfftw.so.2.0.5
/usr/lib64/libsrfftw.a
/usr/lib64/libsrfftw.la
/usr/lib64/libsrfftw.so
/usr/lib64/libsrfftw.so.2
/usr/lib64/libsrfftw.so.2.0.5

Numpy version 0.9.3.1885
Scipy version 0.4.4.1546

scipy.show_config() results in

dfftw_info:
  NOT AVAILABLE

fft_opt_info:
  NOT AVAILABLE

fftw2_info:
  NOT AVAILABLE

fftw3_info:
  NOT AVAILABLE

Hence, the fft libraries are not not detected automatically. How can I
fix this problem ?

Nils




More information about the Scipy-dev mailing list