[SciPy-dev] some sparse errors

Nils Wagner nwagner at mecha.uni-stuttgart.de
Wed Mar 1 07:25:38 CST 2006


Arnd Baecker wrote:
> Hi,
>
> I just updated my numpy/scipy installation and get some errorrs
>
> Out[2]: '0.4.7.1625'
> In [3]: scipy.test(1)
> import io -> failed: invalid syntax (sparse.py, line 2119)
>
> [...]
>
> Warning: FAILURE importing tests for <module 'scipy.sparse' from
> '...ages/scipy/sparse/__init__.pyc'>
> /home/abaecker/NBB/SOFTWARE/morepub/pub_scipy/lib/python2.3/site-packages/scipy/sparse/tests/test_sparse.py:23:
> ImportError: cannot import name csc_matrix (in ?)
>
>
> Note that I am running python 2.3.5
> sparse/sparse.py", line 2119
>      return sum(len(rowvals) for rowvals in self.vals)
>                                ^
> SyntaxError: invalid syntax
>
> This looks like it is some 2.4 syntax being used ?
>
> Best, Arnd
>
> _______________________________________________
> Scipy-dev mailing list
> Scipy-dev at scipy.net
> http://www.scipy.net/mailman/listinfo/scipy-dev
>   


It works fine with python2.4

Nils




More information about the Scipy-dev mailing list