[SciPy-dev] blitz and gcc-4.xx

Balazs Nemeth Balazs.Nemeth at shaw.ca
Fri Oct 13 09:44:59 CDT 2006


Hello,

On a system with gcc version larger than 3 ( Ubuntu 6.06) blitz fails because in 
/usr/lib/python2.4/site-packages/weave/blitz-20001213/blitz/config.h
due to the construction:
..
#if (__GNUC__ && __GNUC__ == 3)
    #define  BZ_HAVE_NUMERIC_LIMITS
#else
    #undef  BZ_HAVE_NUMERIC_LIMITS
#endif
..

BZ_HAVE_NUMERIC_LIMITS limits stays undefined, which is incorrect because it is
defined in
/usr/lib/gcc/x86_64-linux-gnu/4.1.0/include/limits.h

changing the above section to 

..
#if (__GNUC__ && __GNUC__ > 2)
    #define  BZ_HAVE_NUMERIC_LIMITS
#else
    #undef  BZ_HAVE_NUMERIC_LIMITS
#endif
..

solves the problem.

Thanks

BN



More information about the Scipy-dev mailing list