[SciPy-dev] blitz and gcc-4.xx

David M. Cooke cookedm at physics.mcmaster.ca
Fri Oct 13 16:40:06 CDT 2006


On Fri, 13 Oct 2006 14:44:59 +0000 (UTC)
Balazs Nemeth <Balazs.Nemeth at shaw.ca> wrote:

> Hello,
> 
> On a system with gcc version larger than 3 ( Ubuntu 6.06) blitz fails
> because
> in /usr/lib/python2.4/site-packages/weave/blitz-20001213/blitz/config.h due
> to the construction: ..
> #if (__GNUC__ && __GNUC__ == 3)
>     #define  BZ_HAVE_NUMERIC_LIMITS
> #else
>     #undef  BZ_HAVE_NUMERIC_LIMITS
> #endif

You're using the old version of scipy, where weave is a separate package.

The current version doesn't have this problem.

-- 
|>|\/|<
/--------------------------------------------------------------------------\
|David M. Cooke                      http://arbutus.physics.mcmaster.ca/dmc/
|cookedm at physics.mcmaster.ca


More information about the Scipy-dev mailing list