[SciPy-dev] umfpack-5.1

Darren Dale dd55 at cornell.edu
Tue Sep 19 10:24:21 CDT 2006


After updating umfpack to the current version (umfpack-5.1), I am not able to 
build scipy. There is a long list of errors, such as 

/usr/include/umfpack/umfpack.h:31:22: error: UFconfig.h: No such file or 
directory
In file included from /usr/include/umfpack/umfpack.h:48,
                 from 
build/src.linux-x86_64-2.4/Lib/linsolve/umfpack/_umfpack_wrap.c:2478:
/usr/include/umfpack/umfpack_symbolic.h:23: error: 
expected '=', ',', ';', 'asm' or '__attribute__' before 'umfpack_dl_symbolic'
/usr/include/umfpack/umfpack_symbolic.h:47: error: 
expected '=', ',', ';', 'asm' or '__attribute__' before 'umfpack_zl_symbolic'

and 

build/src.linux-x86_64-2.4/Lib/linsolve/umfpack/_umfpack_wrap.c:2810: 
error: 'UF_long' undeclared (first use in this function)
build/src.linux-x86_64-2.4/Lib/linsolve/umfpack/_umfpack_wrap.c:2810: error: 
(Each undeclared identifier is reported only once
build/src.linux-x86_64-2.4/Lib/linsolve/umfpack/_umfpack_wrap.c:2810: error: 
for each function it appears in.)
build/src.linux-x86_64-2.4/Lib/linsolve/umfpack/_umfpack_wrap.c:2810: error: 
expected ';' before 'arg1'

Will scipy support new versions of umfpack?

Thanks,
Darren


More information about the Scipy-dev mailing list