[SciPy-dev] Scipy and LAPACK 3.1.* ?

Nils Wagner nwagner@iam.uni-stuttgart...
Tue Apr 10 06:41:00 CDT 2007


David Cournapeau wrote:
> Hi there,
>
>     I tried to compile numpy/scipy with recent LAPACK and BLAS versions 
> (LAPACK 3.1.1, BLAS from the netlib package, not from LAPACK, using 
> gfortran as a compiler everywhere), and I got several errors when 
> testing scipy:
>
>     ======================================================================
> FAIL: check_syevr (scipy.lib.tests.test_lapack.test_flapack_float)
> ----------------------------------------------------------------------
> Traceback (most recent call last):
>   File 
> "/home/david/local/lib/python2.5/site-packages/scipy/lib/lapack/tests/esv_tests.py", 
> line 41, in check_syevr
>     assert_array_almost_equal(w,exact_w)
>   File 
> "/home/david/local/lib/python2.5/site-packages/numpy/testing/utils.py", 
> line 230, in assert_array_almost_equal
>     header='Arrays are not almost equal')
>   File 
> "/home/david/local/lib/python2.5/site-packages/numpy/testing/utils.py", 
> line 215, in assert_array_compare
>     assert cond, msg
> AssertionError:
> Arrays are not almost equal
>
> (mismatch 33.3333333333%)
>  x: array([-0.66992444,  0.48769468,  9.18222618], dtype=float32)
>  y: array([-0.66992434,  0.48769389,  9.18223045])
>
> ======================================================================
> FAIL: check_syevr_irange (scipy.lib.tests.test_lapack.test_flapack_float)
> ----------------------------------------------------------------------
> Traceback (most recent call last):
>   File 
> "/home/david/local/lib/python2.5/site-packages/scipy/lib/lapack/tests/esv_tests.py", 
> line 66, in check_syevr_irange
>     assert_array_almost_equal(w,exact_w[rslice])
>   File 
> "/home/david/local/lib/python2.5/site-packages/numpy/testing/utils.py", 
> line 230, in assert_array_almost_equal
>     header='Arrays are not almost equal')
>   File 
> "/home/david/local/lib/python2.5/site-packages/numpy/testing/utils.py", 
> line 215, in assert_array_compare
>     assert cond, msg
> AssertionError:
> Arrays are not almost equal
>
> (mismatch 33.3333333333%)
>  x: array([-0.66992444,  0.48769468,  9.18222618], dtype=float32)
>  y: array([-0.66992434,  0.48769389,  9.18223045])
>
> ----------------------------------------------------------------------
>
> The different dtype may suggest an error while compiling the 
> BLAS/LAPACK, but I tested the libraries with official tester without any 
> error.
>
> cheers,
>
> David
> _______________________________________________
> Scipy-dev mailing list
> Scipy-dev@scipy.org
> http://projects.scipy.org/mailman/listinfo/scipy-dev
>   
Hi David,

I can confirm your findings.
BTW, is there a way to obtain the information which version of LAPACK is
used via scipy.show_config() ?
I mean something like [('ATLAS_INFO', '"\\"3.7.28\\""')]

Cheers,

                 Nils
 


More information about the Scipy-dev mailing list