[SciPy-dev] Requiring Python 2.4

Stefan van der Walt stefan@sun.ac...
Tue Aug 28 18:21:40 CDT 2007


On Tue, Aug 28, 2007 at 05:47:06PM -0500, Robert Kern wrote:
> I would like to maintain compatibility with as old a Python as we
> can for as long as we can. I think we should have a compelling
> reason to drop support for a version of Python that is more than
> just the age of that version.

Fair enough.  For some reason I was under the impression that list
comprehension was a 2.4 feature, but as Lino pointed out, it's been
around forever.  The rest of the features introduced in 2.4 were
fairly minor, and we can work around decorators.  The Python 2.5 list
is more exciting:

http://docs.python.org/whatsnew/whatsnew25.html

Especially conditional expressions, partial functions, and 'with' context
managers.  Nothing we can't live without, though.

Thanks for the feedback.
Stéfan




More information about the Scipy-dev mailing list