[SciPy-dev] sparsetools_wrap.cxx

Nathan Bell wnbell at gmail.com
Tue Jan 9 11:00:50 CST 2007


On 1/9/07, Nathan Bell <wnbell at gmail.com> wrote:
> On 1/9/07, Jeremy Conlin <jeremit0 at gmail.com> wrote:
> > I just checked out the latest version of scipy (revision 2512).  When
> > compiling I get the following errors:
>
> Try 2513, it should fix your problem.

I should have elaborated.  The problem is caused by using an older
version of SWIG to generate the wrappers.  As Robert Kern pointed out
in a previous thread:

"""
Please use SWIG CVS to generate those files. Most of the errors that Nils
reported are from non-const-preserving assignments in the SWIG runtime
functions. g++ 4 is stricter about those than g++ 3. SWIG CVS corrects those
problems.
"""

It appears that Apple's g++4 is more sensitive to this issue than
other those in other distributions.


When generating the SWIG wrappers for sparsetools, be sure to use the
most recent version of SWIG (i.e. the one currently in svn).


-- 
Nathan Bell wnbell at gmail.com


More information about the Scipy-dev mailing list