[SciPy-dev] ImportError: No module named distutils.ccompiler

Robert Kern robert.kern@gmail....
Mon Nov 5 10:05:53 CST 2007


Nils Wagner wrote:
> Hi all,
> 
> I cannot install the latest svn version of numpy (r4380).
> I am using python2.3 on x86_64.
> 
> python setup.py install --prefix=$HOME/local
> Running from numpy source directory.
> Traceback (most recent call last):
>    File "setup.py", line 90, in ?
>      setup_package()
>    File "setup.py", line 62, in setup_package
>      from numpy.distutils.core import setup
>    File 
> "/data/home/nwagner/svn/numpy/numpy/distutils/__init__.py", 
> line 6, in ?
>      import ccompiler
>    File 
> "/data/home/nwagner/svn/numpy/numpy/distutils/ccompiler.py", 
> line 6, in ?
>      from distutils.ccompiler import *
> ImportError: No module named distutils.ccompiler

Do you have the appropriate python-dev/python-devel package installed?

-- 
Robert Kern

"I have come to believe that the whole world is an enigma, a harmless enigma
 that is made terrible by our own mad attempt to interpret it as though it had
 an underlying truth."
  -- Umberto Eco


More information about the Scipy-dev mailing list