[SciPy-dev] swig dependency

Jarrod Millman millman@berkeley....
Thu Oct 4 14:23:36 CDT 2007


On 10/4/07, Christopher Hanley <chanley@stsci.edu> wrote:
> I see that the latest revision of scipy (r3410) now has a swig
> dependency.  What version of swig is now required?  I am unable to build
> scipy with swig version 1.1 (Patch 5).

SciPy has required SWIG for at least a year.  I am just starting to
work with SWIG, but I am using SWIG 1.3.31.  It looks like SWIG 1.3
was released in 2000.

> Also, is there a place on the scipy site that I can find a listing of
> all the dependencies and associated version numbers?

I took a quick look and couldn't find a list of prereqs.  If noone
else gets to it first, I will try and update the site.

Thanks,
Jarrod


More information about the Scipy-dev mailing list