[SciPy-dev] swig dependency

Robert Kern robert.kern@gmail....
Thu Oct 4 16:04:11 CDT 2007


Jarrod Millman wrote:
> On 10/4/07, Christopher Hanley <chanley@stsci.edu> wrote:
>> I see that the latest revision of scipy (r3410) now has a swig
>> dependency.  What version of swig is now required?  I am unable to build
>> scipy with swig version 1.1 (Patch 5).
> 
> SciPy has required SWIG for at least a year. 

That's not entirely true. The UMFPACK bindings are optional, and sparsetools has
the generated files checked in so that no one except those modifying those
wrappers needs to have SWIG installed. Checking generated files into source
control is somewhat icky, but so is having to answer this question over and over.

-- 
Robert Kern

"I have come to believe that the whole world is an enigma, a harmless enigma
 that is made terrible by our own mad attempt to interpret it as though it had
 an underlying truth."
  -- Umberto Eco


More information about the Scipy-dev mailing list