[SciPy-dev] scikits svn doesn't work?

Robert Kern robert.kern@gmail....
Mon Oct 15 13:43:32 CDT 2007


dmitrey wrote:
> Robert Kern wrote:
>> dmitrey wrote:
>>   
>>> Hi all,
>>> I have some problems with svn, when I try to commit or update, it yields 
>>> (for example, for ralg.py):
>>>
>>> svn: Unrecognized URL scheme for 
>>> 'http://svn.scipy.org/svn/scikits/trunk/openopt/scikits/openopt/solvers/UkrOpt/ralg.py'
>>> or (if I call from upper level)
>>> svn: Unrecognized URL scheme for 
>>> 'http://svn.scipy.org/svn/scikits/trunk/openopt/scikits/openopt/solvers'
>>>
>>> Any idea?
>>>     
>> Are you using Ubuntu? Do you have feisty-proposed as one of your apt
>> repositories? A broken subversion dpkg was uploaded to feisty-proposed in the
>> past couple of days. It's missing the plugin that lets you access http:// SVN
>> repositories. Downgrade to the version in feisty: 1.4.3dfsg1-1ubuntu1.
>>
>> This convinced me not to use the *-proposed repositories anymore.
>>
> Yes, that's the matter. How it can be done? I have tried to install the 
> version 1.4.3dfsg1-1ubuntu1 but it yields "error - more later version is 
> already installed".

I use aptitude. I searched for the "subversion" package and pressed Enter to
view its details. At the bottom, it shows you the versions that are available,
and I selected 1.4.3dfsg1-1ubuntu1. It may help to remove feisty-proposed from
your list of repositories and update the package list.

-- 
Robert Kern

"I have come to believe that the whole world is an enigma, a harmless enigma
 that is made terrible by our own mad attempt to interpret it as though it had
 an underlying truth."
  -- Umberto Eco


More information about the Scipy-dev mailing list