[SciPy-dev] problems with numpy.setuptools("single_version_externally_managed")

Pearu Peterson pearu@cens.ioc...
Tue Sep 25 14:19:26 CDT 2007


On Tue, September 25, 2007 6:57 pm, David M. Cooke wrote:
> On Tue, Sep 25, 2007 at 06:51:15PM +0300, Pearu Peterson wrote:
>> On Tue, September 25, 2007 6:43 pm, David M. Cooke wrote:
>> >
>> > Fixed that for you. See r4134.

Though, I am not sure if this is a proper fix.

Importing, say, distutils.msvccompiler may trigger
messages that may be completely irrelevant.
E.g. in my linux box:

>>> from distutils import log
>>> log.set_verbosity(4)
>>> import distutils.msvccompiler
Warning: Can't read registry to find the necessary compiler setting
Make sure that Python modules _winreg, win32api or win32con are installed.

I think distutils.*compiler modules are not designed to be
imported unless specifically requested via --compiler flag.
Though only importing distutils.msvccompiler has side effect.
A seemingly easy fix would be to use the fix by checking os.name
and sys.platform but if one is using mingw32 compiler under windows,
the given warnings would be still wrong.

But we'll see if this will be an issue in future..

Pearu



More information about the Scipy-dev mailing list