[SciPy-dev] import scipy.linalg in svn

Robert Kern robert.kern@gmail....
Tue Apr 8 16:31:55 CDT 2008


On Tue, Apr 8, 2008 at 2:24 PM, Nathan Bell <wnbell@gmail.com> wrote:
> On Tue, Apr 8, 2008 at 4:12 PM, Nils Wagner
>  <nwagner@iam.uni-stuttgart.de> wrote:
>  > I guess I found a blocker in scipy svn
>  >  >>> scipy.__version__
>  >  '0.7.0.dev4118'
>
> >  "/usr/lib/python2.4/site-packages/scipy/sparse/linalg/eigen/lobpcg/lobpcg.py",
>  >  line 21, in ?
>  >      import scipy.linalg as sla
>  >  AttributeError: 'module' object has no attribute 'linalg'
>  >
>  >  Am I missing something ?
>
>  I committed a workaround in r4120.  There's a circular chain of
>  imports due to the deprecated iterative solvers that lived in
>  scipy.linalg.iterative and now reside in scipy.sparse.linalg.isolve
>  http://projects.scipy.org/scipy/scipy/changeset/4120
>
>  Please let me know if there's a better way to fix this problem.

Except for removing the deprecated parts in scipy.linalg.iterative,
this is a perfectly acceptable workaround.

-- 
Robert Kern

"I have come to believe that the whole world is an enigma, a harmless
enigma that is made terrible by our own mad attempt to interpret it as
though it had an underlying truth."
 -- Umberto Eco


More information about the Scipy-dev mailing list