[SciPy-dev] scipy compile problems

David Cournapeau david@ar.media.kyoto-u.ac...
Mon Aug 4 04:22:55 CDT 2008


Nate wrote:
> I'm having trouble compiling scipy from the repo on Ubuntu (8.04).  See the
> following output error from scipy.test().  Apparently there are problems with
> lapack. 

Please use the Ubuntu provided atlas if you don't have a strong reason
not to, it will be much easier to deal with:

sudo apt-get install libatlas-base-dev libatlas-sse2 # for gfortran
sudo apt-get install atlas3-base-dev atlas3-sse2 # for g77

And once you selected one of them, clean the build directory and install
directory for both numpy and scipy, and start from scratch:

python setup.py build --fortran=gnu95 install # gfortran
python setup.py build install # g77

There should be no need for site.cfg, numpy knows about the location
under ubuntu/debian.

cheers,

David


More information about the Scipy-dev mailing list