[SciPy-dev] scikits.umfpack

Robert Cimrman cimrman3@ntc.zcu...
Wed Aug 6 06:15:49 CDT 2008


Nils Wagner wrote:
> On Tue, 05 Aug 2008 18:33:10 +0200
>   Robert Cimrman <cimrman3@ntc.zcu.cz> wrote:
>> Nils Wagner wrote:
>>> Hi Robert C.,
>>>
>>> I saw that you have edited __init__.py today.
>>>   
>>>>>> from scikits import umfpack
>>>>>> umfpack.test()
>>> Running unit tests for scikits.umfpack
>>> NumPy version 1.2.0.dev5611
>>> NumPy is installed in 
>>> /usr/lib/python2.4/site-packages/numpy
>>> Python version 2.4 (#1, Oct 13 2006, 17:13:31) [GCC 
>>> 3.3.5 
>>> 20050117 (prerelease) (SUSE Linux)]
>>> nose version 0.10.3
>>> E
>>> ======================================================================
>>> ERROR: Failure: ImportError (No module named testing)
>>> ----------------------------------------------------------------------
>>> Traceback (most recent call last):
>>>    File 
>>> "/usr/lib/python2.4/site-packages/nose-0.10.3-py2.4.egg/nose/loader.py", 
>>> line 363, in loadTestsFromName
>>>      module = self.importer.importFromPath(
>>>    File 
>>> "/usr/lib/python2.4/site-packages/nose-0.10.3-py2.4.egg/nose/importer.py", 
>>> line 39, in importFromPath
>>>      return self.importFromDir(dir_path, fqname)
>>>    File 
>>> "/usr/lib/python2.4/site-packages/nose-0.10.3-py2.4.egg/nose/importer.py", 
>>> line 84, in importFromDir
>>>      mod = load_module(part_fqname, fh, filename, desc)
>>>    File 
>>> "/usr/lib/python2.4/site-packages/scikits/umfpack/tests/test_umfpack.py", 
>>> line 13, in ?
>>>      from scipy.testing import *
>>> ImportError: No module named testing
>>>
>>> ----------------------------------------------------------------------
>>> Ran 1 test in 0.088s
>>>
>>> FAILED (errors=1)
>>> <nose.result.TextTestResult run=1 errors=1 failures=0>
>>>
>>> Nils
>> Hi Nils,
>>
>> I have to do it so that it works with the latest SVN 
>> version 
>> (0.7.0.dev4600), but may have done something wrong. The 
>> prior version is 
>> ok for you?
>>
>> r.
> 
> Robert,
> 
> The problem is that IIRC scipy.testing is not longer used.
> Please correct me if I am missing something.
>   
> In [1]: import scipy
> 
> In [2]: scipy.te
> scipy.tensordot  scipy.test
> 
> In [2]: scipy.te
> scipy.tensordot  scipy.test
> 
> In [2]: import numpy
> 
> In [3]: numpy.t
> numpy.take         numpy.tensordot    numpy.tile 
>         numpy.trapz        numpy.trim_zeros 
>   numpy.typeDict     numpy.typename
> numpy.tan          numpy.test         numpy.trace 
>        numpy.tri          numpy.triu         numpy.typeNA
> numpy.tanh         numpy.testing      numpy.transpose 
>    numpy.tril         numpy.true_divide  numpy.typecodes

Hi Nils,

it looks like you have numpy.testing too, so the fix might be ok.

The error you see comes from test_umfpack.py not being updated to new 
testing framework. So what is the current way of importing Tester? 
numpy.testing works for me.

my installation behaves in the following way:

# original:
In [7]: from scipy.testing.pkgtester import Tester
---------------------------------------------------------------------------
ImportError                               Traceback (most recent call last)

/home/eldaran/<ipython console>

ImportError: No module named testing.pkgtester

# new:
In [8]: from numpy.testing import Tester

In [9]: import numpy
In [10]: numpy.__version__
Out[10]: '1.2.0.dev5615'
In [11]: import scipy
In [12]: scipy.__version__
Out[12]: '0.7.0.dev4603'


Related question: what versions of scipy/numpy should be scikits 
compatible with? I will try to update umfpack to work both with the last 
release and the svn.

r.


More information about the Scipy-dev mailing list