[SciPy-dev] test_arpack errors on 64bit Linux

Aric Hagberg hagberg@lanl....
Sat Aug 16 09:51:26 CDT 2008


On Thu, Aug 14, 2008 at 06:41:37PM -0600, Aric Hagberg wrote:
> On Thu, Aug 14, 2008 at 01:26:28PM -0700, Jarrod Millman wrote:
> > I am getting test_arpack errors on 64bit Linux, but not 32bit Linux.
> > Is anyone else seeing this?  I would like to get these fixed before
> > releasing the 0.7.0b1.
> 
> I can verify that I get errors in the same tests - but slightly
> different errors.  I see an info=-8 and info=-9999 return form ARPACK
> in addition to info=-9 
> 
> Is there some LAPACK/BLAS issue?

It appears that the problem is with ATLAS package on 64bit Linux.

I rebuilt ATLAS from source (atlas-3.8.2) and all of the tests pass.  

This is the configuration that *doesn't* work (Ubuntu 64 bit):

>>> scipy.test()
Running unit tests for scipy
NumPy version 1.2.0.dev5654
NumPy is installed in /u/aric/lib/python/numpy
SciPy version 0.7.0.dev4645
SciPy is installed in /u/aric/lib/python/scipy
Python version 2.5.2 (r252:60911, Jul 31 2008, 17:31:22) [GCC 4.2.3
(Ubuntu 4.2.3-2ubuntu7)]
nose version 0.10.0
...
fail on arpack tests (and others)

$ dpkg -l |grep atlas
ii  atlas3-base                                      3.6.0-20.6
ii  atlas3-base-dev                                  3.6.0-20.6
ii  atlas3-headers                                   3.6.0-20.6

$ gfortran -v
Using built-in specs.
Target: x86_64-linux-gnu
Configured with: ../src/configure -v
--enable-languages=c,c++,fortran,objc,obj-c++,treelang --prefix=/usr
--enable-shared --with-system-zlib --libexecdir=/usr/lib
--without-included-gettext --enable-threads=posix --enable-nls
--with-gxx-include-dir=/usr/include/c++/4.2 --program-suffix=-4.2
--enable-clocale=gnu --enable-libstdcxx-debug --enable-objc-gc
--enable-mpfr --enable-checking=release --build=x86_64-linux-gnu
--host=x86_64-linux-gnu --target=x86_64-linux-gnu
Thread model: posix
gcc version 4.2.3 (Ubuntu 4.2.3-2ubuntu7)

Aric

  


More information about the Scipy-dev mailing list