[SciPy-dev] Umfpack deprecation warning

Nathan Bell wnbell@gmail....
Mon Dec 1 09:03:34 CST 2008


On Mon, Dec 1, 2008 at 8:06 AM, Pauli Virtanen <pav@iki.fi> wrote:
>
> This is a bit annoying as it comes up basically for all scripts that
> import Scipy.
>

I don't have umfpack installed, so I can't test it myself.  Please try
the following:

Index: scipy/sparse/linalg/dsolve/linsolve.py
===================================================================
--- scipy/sparse/linalg/dsolve/linsolve.py	(revision 5213)
+++ scipy/sparse/linalg/dsolve/linsolve.py	(working copy)
@@ -15,10 +15,6 @@

 isUmfpack = hasattr( umfpack, 'UMFPACK_OK' )

-if isUmfpack and noScikit:
-    warn( 'scipy.sparse.linalg.dsolve.umfpack will be removed,'
-          ' install scikits.umfpack instead', DeprecationWarning )
-
 useUmfpack = True


@@ -77,6 +73,9 @@


     if isUmfpack and useUmfpack:
+        if noScikit:
+            warn( 'scipy.sparse.linalg.dsolve.umfpack will be removed,'\
+                    ' install scikits.umfpack instead', DeprecationWarning )
         if A.dtype.char not in 'dD':
             raise ValueError, "convert matrix data to double, please, using"\
                   " .astype(), or set linsolve.useUmfpack = False"
@@ -139,6 +138,10 @@
       x2 = solve( rhs2 ) # Uses again the LU factors.
     """
     if isUmfpack and useUmfpack:
+        if noScikit:
+            warn( 'scipy.sparse.linalg.dsolve.umfpack will be removed,'\
+                    ' install scikits.umfpack instead', DeprecationWarning )
+
         if not isspmatrix_csc(A):
             A = csc_matrix(A)
             warn('splu requires CSC matrix format', SparseEfficiencyWarning)



-- 
Nathan Bell wnbell@gmail.com
http://graphics.cs.uiuc.edu/~wnbell/


More information about the Scipy-dev mailing list