[SciPy-dev] 1 Failure in 0.7.0b1

Bruce Southey bsouthey@gmail....
Mon Dec 1 16:02:19 CST 2008


Xavier Gnata wrote:
>>> On Mon, Dec 1, 2008 at 8:12 AM, Xavier Gnata <xavier.gnata@gmail.com>
>>> wrote:
>>>
>>>       
>>>> Ok I can reproduce this one on intrepid ibex 64bits (gfortran).
>>>> The funny think is that I think (if I read the correct mathword pages)
>>>> that 1.0 is the correct answer (but it is so easy to be wrong with these
>>>> special function).
>>>>         
>>> I can't reproduce on RHEL 5 (64 bits/python2.4). I opened a ticket:
>>>
>>> http://scipy.org/scipy/scipy/ticket/803
>>>
>>> Neal, Xavier, which version of numpy are you using ? Which version of
>>> gcc is used in FC 9 ?
>>>
>>> thanks,
>>>
>>> David
>>>       
>> : numpy.__version__
>> Out[3]: '1.2.0'
>>
>> gcc-4.3.0-8.x86_64
>>     
>
> It is starting to be a bit fun :)
>
> gcc version 4.3.2 (Ubuntu 4.3.2-1ubuntu11)
> no g77, only gfortran
> numpy.__version__  '1.3.0.dev6129'
> scipy.__version__ '0.7.0.dev5213'
>
> If there is any other test I should do please tell (I have no time to
> try to really debug this week but I can perform tests).
>
> Xavier
> _______________________________________________
> Scipy-dev mailing list
> Scipy-dev@scipy.org
> http://projects.scipy.org/mailman/listinfo/scipy-dev
>   
Hi
I also get this on my system:
Linux x86-64 Fedora rawhide/10 using Fedora Python 2.5.2 (r252:60911), 
GCC (4.3.2 20080917 (Red Hat 4.3.2-4)), and Fedora supplied blas/atlas 
libraries. My Numpy is '1.3.0.dev6006' or an earlier version of 1.3 but 
Numpy was not built with any blas/atlas libraries. (Yes, scipy will 
build if a site.cfg is provided otherwise it will not because it looks 
at the numpy installation).

It also fails for
Python 2.4.5 built from source using gcc 4.3.2
Python 2.6 (r26:66714, Oct  2 2008, 11:15:01) built from source using 
gcc 4.3.2 - others also fail here.

Bruce





More information about the Scipy-dev mailing list