[SciPy-dev] error installing matplotlib-0.98.5

Neal Becker ndbecker2@gmail....
Fri Dec 12 11:55:44 CST 2008


sudo easy_install -U matplotlib
Searching for matplotlib
Reading http://pypi.python.org/simple/matplotlib/
Reading http://matplotlib.sourceforge.net
Reading https://sourceforge.net/project/showfiles.php?group_id=80706&package_id=278194
Reading https://sourceforge.net/project/showfiles.php?group_id=80706&package_id=82474
Reading http://sourceforge.net/project/showfiles.php?group_id=80706
Best match: matplotlib 0.98.5
Downloading http://downloads.sourceforge.net/matplotlib/matplotlib-0.98.5.tar.gz?modtime=1229034572&big_mirror=0
Processing matplotlib-0.98.5.tar.gz
Running matplotlib-0.98.5/setup.py -q bdist_egg --dist-dir /tmp/easy_install-CC1jw7/matplotlib-0.98.5/egg-dist-tmp-NSNvcC
============================================================================
BUILDING MATPLOTLIB
            matplotlib: 0.98.5
                python: 2.5.2 (r252:60911, Sep 30 2008, 15:42:03)  [GCC
                        4.3.2 20080917 (Red Hat 4.3.2-4)]
              platform: linux2

REQUIRED DEPENDENCIES
                 numpy: 1.2.0
             freetype2: 9.18.3

OPTIONAL BACKEND DEPENDENCIES
                libpng: 1.2.33
               Tkinter: Tkinter: 50704, Tk: 8.5, Tcl: 8.5
                        * Guessing the library and include directories for
                        * Tcl and Tk because the tclConfig.sh and
                        * tkConfig.sh could not be found and/or parsed.
              wxPython: 2.8.9.1
                        * WxAgg extension not required for wxPython >= 2.8
                  Gtk+: gtk+: 2.14.4, glib: 2.18.3, pygtk: 2.13.0,
                        pygobject: 2.15.4
       Mac OS X native: no
                    Qt: Qt: 3.3.8, PyQt: 3.17.4
                   Qt4: Qt: 4.4.1, PyQt4: 4.4.3
                 Cairo: 1.4.12

OPTIONAL DATE/TIMEZONE DEPENDENCIES
              datetime: present, version unknown
              dateutil: 1.4
                  pytz: 2006p

OPTIONAL USETEX DEPENDENCIES
                dvipng: 1.11
           ghostscript: 8.63
                 latex: 3.141592

EXPERIMENTAL CONFIG PACKAGE DEPENDENCIES
             configobj: 4.5.2
      enthought.traits: no

[Edit setup.cfg to suppress the above messages]
============================================================================
error: lib/matplotlib/mpl-data/matplotlib.conf.template: No such file or directory
Exception exceptions.OSError: (2, 'No such file or directory', 'src/image.cpp') in <bound method CleanUpFile.__del__ of <setupext.CleanUpFile instance at 0x7fc85b3c51b8>> ignored
Exception exceptions.OSError: (2, 'No such file or directory', 'src/path.cpp') in <bound method CleanUpFile.__del__ of <setupext.CleanUpFile instance at 0x7fc85b3c4638>> ignored
Exception exceptions.OSError: (2, 'No such file or directory', 'src/backend_gdk.c') in <bound method CleanUpFile.__del__ of <setupext.CleanUpFile instance at 0x7fc85978c7a0>> ignored
Exception exceptions.OSError: (2, 'No such file or directory', 'src/backend_agg.cpp') in <bound method CleanUpFile.__del__ of <setupext.CleanUpFile instance at 0x7fc85b3c4fc8>> ignored




More information about the Scipy-dev mailing list