[SciPy-dev] umfpack scikit

Robert Cimrman cimrman3@ntc.zcu...
Thu Feb 7 07:34:19 CST 2008


Hi,

I have the first version of the scikit ready but it seems I have not 
rights to commit (username 'rc'). Can somebody help please?

Concerning the umfpack files from scipy.splinalg.dsolve, I would let 
them in place for some transition period. I will add something like the 
code below to linsolve.py:

--
if isUmfpack and noScikit:
     warn( 'scipy.splinalg.dsolve.umfpack has moved, install 
scikits.umfpack instead', DeprecationWarning )
--

The scikit now contains the same code that was in 
scipy.splinalg.dsolve.umfpack, I did not include the GPL-ed umfpack 
sources. What is your opinion?

1. Let the wrappers BSD and install umfpack libraries separately as it 
is now,
2. or include everything and change the scikit license to GPL.

I am more for option 1., as on my system (Gentoo Linux) umfpack 
libraries exist as a standard package and the installation is trivial. 
This is IMHO true on other systems too. I also like BSD license more for 
my code.

r.


More information about the Scipy-dev mailing list