[SciPy-dev] Mac leopard and scipy sparse status

Nathan Bell wnbell@gmail....
Wed Jan 16 04:57:36 CST 2008


On Jan 15, 2008 1:00 PM, John Ollinger <ollinger@wisc.edu> wrote:
>
> I have been porting my numpy/scipy apps to my new imac for the last week or
> so , and have been getting seg faults in the sparse matrix package for the
> available binary build.  I  rebuilt lapack, atlas, umfpack and numpy from
> sources without problems, but the scipy build crashes while wrapping
> umfpack.  I recall seeing some traffic about modifications to the sparse
> matrix package, and am wondering if I should get the svn version of this
> package before I starting working on the problem.  It is probably just a
> change in the swig include file, but  I use this package a lot and would
> like to start with  a more recent version if there have been significant
> changes.

When you say "seg faults in the sparse matrix package" do you mean
problems with UMFPACK/SuperLU or general sparse problems?

Also, what error do you get when wrapping UMFPACK?  Do you have a
recent version of SWIG installed?


-- 
Nathan Bell wnbell@gmail.com
http://graphics.cs.uiuc.edu/~wnbell/


More information about the Scipy-dev mailing list