[SciPy-dev] SyntaxError in scikits/learn arffread.py

David Cournapeau david@ar.media.kyoto-u.ac...
Thu Jan 17 22:49:54 CST 2008


Nils Wagner wrote:
> Hi all,
>
> I have installed the scikits package learn from scratch.
>
> Compiling 
> /usr/lib/python2.4/site-packages/scikits/learn/utils/arffread.py 
> ...
>    File 
> "/usr/lib/python2.4/site-packages/scikits/learn/utils/arffread.py", 
> line 401
>      finally:
>            ^
> SyntaxError: invalid syntax
>   
The problem is that I used the try/except/finally syntax, which was 
introduced in python 2.5 only.

The learn package is a bit in limbo because I focused my free-time (and 
more :) ) on numscons, but once this is finished, I intend to go back on 
scikits.learn (there is a strong guarantee I will work on it in the next 
few months, if only for the reason that I need it for my PhD).

cheers,

David


More information about the Scipy-dev mailing list