[SciPy-dev] problem with import scipy.sparse

Nathan Bell wnbell@gmail....
Tue Jun 3 09:13:42 CDT 2008


On Mon, Jun 2, 2008 at 11:59 PM, Tom Waite <twaite@berkeley.edu> wrote:
> I get the following error when I try to import the latest version of scipy
> sparse. This is the first I have seen of this and I use sparse w/o any
> problems prior to this.
>
> In [3]: import scipy.sparse
> --> 139     @deprecate
>     140     def rowcol(self, num):
>     141         return (None, None)
>
> <type 'exceptions.TypeError'>: deprecate() takes exactly 3 arguments (1
> given)
>
> In [4]: scipy.__version__
> Out[4]: '0.7.0.dev4402'

Which version of numpy are you using? IIRC you need a something newer than 1.0.


-- 
Nathan Bell wnbell@gmail.com
http://graphics.cs.uiuc.edu/~wnbell/


More information about the Scipy-dev mailing list