[SciPy-dev] Scikits version system

Robert Kern robert.kern@gmail....
Mon Jun 16 20:40:44 CDT 2008


On Mon, Jun 16, 2008 at 20:18, Pierre GM <pgmdevlist@gmail.com> wrote:
> Folks,
> I'm trying to add some version number to our package (timeseries), following
> the example in http://scipy.org/scipy/scikits/wiki/ScikitsForDevelopers
> However, something must be going wrong, as the only __version__ number I get
> is 0.5, no matter the version number I try to set.

Well, the current trunk doesn't build into an egg for me: you have
tag_svn_revision set to an invalid value in setup.cfg. You also have
the name of the package wrong in the setup() call, so it makes and egg
called "timeseries" rather than "scikits.timeseries" which is what it
should be. Fixing these, and uncommenting out the implementation of
the scheme described on the wiki works for me.

Attached is the patch against SVN trunk.

In doing this, I found a few places where there are mixed line
endings. Please take a look at normalizing these. Also please go
through the commented-out blocks of obsolete code and delete any of it
that you can. SVN remembers so the file doesn't have to.

-- 
Robert Kern

"I have come to believe that the whole world is an enigma, a harmless
enigma that is made terrible by our own mad attempt to interpret it as
though it had an underlying truth."
 -- Umberto Eco
-------------- next part --------------
A non-text attachment was scrubbed...
Name: scikits.timeseries-version.patch
Type: application/octet-stream
Size: 1678 bytes
Desc: not available
Url : http://projects.scipy.org/pipermail/scipy-dev/attachments/20080616/38de1b11/attachment.obj 


More information about the Scipy-dev mailing list