[SciPy-dev] [GSoC 2008]Machine learning package in SciPy

Charles Doutriaux doutriaux1@llnl....
Wed Mar 12 13:42:06 CDT 2008


Ok my last error was because i was in the trunk directory, seems to 
create issues.

The latest versino indeed fixes the deprecate issue.

BUT it breaks the oldnumeric.ma which i need too...

Thanks for the suggestion, for now knowing it'll be fix in the next 
release  satisfies me :) (as long it is not too far away)

C.

Matthieu Brucher wrote:
> Hi,
>
> I had the same error (but with Python 2.5.1). This is numpy related, 
> update your version and everything will be fine ;)
>
> Matthieu
>
> 2008/3/12, Charles Doutriaux <doutriaux1@llnl.gov 
> <mailto:doutriaux1@llnl.gov>>:
>
>     Hi there
>
>     It seems that ever since I switched to Python 2.5.2 I get (no matter
>     which version of scipy)
>
>     Any idea?
>
>     C.
>
>       >>> import scipy.linalg
>     Traceback (most recent call last):
>       File "<stdin>", line 1, in <module>
>       File
>     "/lgm/cdat/5.0.0.alpha7/lib/python2.5/site-packages/scipy/linalg/__init__.py",
>     line 13, in <module>
>         from iterative import *
>       File
>     "/lgm/cdat/5.0.0.alpha7/lib/python2.5/site-packages/scipy/linalg/iterative.py",
>     line 5, in <module>
>         from scipy.splinalg import isolve
>       File
>     "/lgm/cdat/5.0.0.alpha7/lib/python2.5/site-packages/scipy/splinalg/__init__.py",
>     line 5, in <module>
>         from isolve import *
>       File
>     "/lgm/cdat/5.0.0.alpha7/lib/python2.5/site-packages/scipy/splinalg/isolve/__init__.py",
>     line 4, in <module>
>         from iterative import *
>       File
>     "/lgm/cdat/5.0.0.alpha7/lib/python2.5/site-packages/scipy/splinalg/isolve/iterative.py",
>     line 18, in <module>
>         from scipy.splinalg.interface import LinearOperator
>       File
>     "/lgm/cdat/5.0.0.alpha7/lib/python2.5/site-packages/scipy/splinalg/interface.py",
>     line 3, in <module>
>         from scipy.sparse.sputils import isshape
>       File
>     "/lgm/cdat/5.0.0.alpha7/lib/python2.5/site-packages/scipy/sparse/__init__.py",
>     line 5, in <module>
>         from base import *
>       File
>     "/lgm/cdat/5.0.0.alpha7/lib/python2.5/site-packages/scipy/sparse/base.py",
>     line 45, in <module>
>         class spmatrix(object):
>       File
>     "/lgm/cdat/5.0.0.alpha7/lib/python2.5/site-packages/scipy/sparse/base.py",
>     line 139, in spmatrix
>         @deprecate
>     TypeError: deprecate() takes exactly 3 arguments (1 given)
>
>     _______________________________________________
>     Scipy-dev mailing list
>     Scipy-dev@scipy.org <mailto:Scipy-dev@scipy.org>
>     http://projects.scipy.org/mailman/listinfo/scipy-dev
>
>
>
>
> -- 
> French PhD student
> Website : http://matthieu-brucher.developpez.com/
> Blogs : http://matt.eifelle.com and http://blog.developpez.com/?blog=92
> LinkedIn : http://www.linkedin.com/in/matthieubrucher
> ------------------------------------------------------------------------
>
> _______________________________________________
> Scipy-dev mailing list
> Scipy-dev@scipy.org
> http://projects.scipy.org/mailman/listinfo/scipy-dev
>   


More information about the Scipy-dev mailing list