[SciPy-dev] scikits learn

Stéfan van der Walt stefan@sun.ac...
Mon Mar 17 10:53:17 CDT 2008


On Mon, Mar 17, 2008 at 3:33 PM, Bruce Southey <bsouthey@gmail.com> wrote:
>  This should be reported as a bug as should any Python 2.4 version code
>  because neither NumPy nor SciPy require only a 2.5 series of Python:
>
>  The SciPy FAQ (http://www.scipy.org/FAQ) page states that NumPy requires
>  Python 2.3.x or 2.4.x or 2.5.x
>  SciPy General building instructions:
>  http://www.scipy.org/Installing_SciPy/BuildingGeneral - To build SciPy,
>  Python version 2.3 or newer is required.

NumPy requires >= 2.3 and SciPy >= 2.4.  There is currently no
guideline for the scikits, and their authors decide for themselves.

Interestingly, ipython will soon move to 2.5 and make use of the
'with' statement to grab code blocks.

Cheers
Stéfan


More information about the Scipy-dev mailing list