[SciPy-dev] scipy doc and python 2.4

Nils Wagner nwagner@iam.uni-stuttgart...
Sun Nov 16 12:45:51 CST 2008


Hi all,
  
AFAIK scipy 0.7 requires python 2.4 and higher.
"finally" is not available in 2.4.

Failed to import 'scipy.fftpack.dftfreq':
Failed to import 
'scipy.io.wavfile.scipy.io.arff.loadarff':
Failed to import 'scipy.signal.medfilt2':
Failed to import 'scipy.stats.anova':
Failed to import 'scipy.stats.fretcher_l':
Failed to import 'scipy.stats.fretchet_r':
Failed to import 'scipy.stats.meanwhitneyu':
Failed to import 'scipy.stats.paired':
Failed to import 'scipy.stats.von_mises':
touch build/generate-stamp
mkdir -p build/html build/doctrees
LANG=C sphinx-build -b html -d build/doctrees   source 
build/html
Exception occurred:
   File 
"/usr/lib/python2.4/site-packages/Sphinx-0.5dev_20081113-py2.4.egg/sphinx/application.py", 
line 161, in setup_extension
     mod = __import__(extension, None, None, ['setup'])
   File 
"/home/nwagner/svn/scipy/doc/ext/plot_directive.py", line 
64
     finally:
           ^
SyntaxError: invalid syntax

Nils


More information about the Scipy-dev mailing list