[SciPy-dev] scipy doc and python 2.4

Pauli Virtanen pav@iki...
Sun Nov 16 12:59:52 CST 2008


Sun, 16 Nov 2008 19:45:51 +0100, Nils Wagner wrote:
> AFAIK scipy 0.7 requires python 2.4 and higher. "finally" is not
> available in 2.4.
[clip]
> "/home/nwagner/svn/scipy/doc/ext/plot_directive.py", line 64
>      finally:
>            ^
> SyntaxError: invalid syntax


Finally is available in 2.4, but not the combined try-except-finally. 
Fixed.

-- 
Pauli Virtanen



More information about the Scipy-dev mailing list